SOFORT: Resolved Service Disruption

Incident Report for PPRO Acquiring Platform

Resolved

The external service disruption of SOFORT has been resolved and the service is again operating inside the normal performance parameters. Please refer to our official Service Announcement emails for further details.
Posted Jan 30, 2025 - 14:41 UTC

Investigating

We are currently investigating this issue.
Posted Jan 30, 2025 - 14:19 UTC
This incident affected: Payment Methods (Klarna Sofort).