Transaction Processing Platform: Unscheduled Maintenance

Incident Report for PPRO Acquiring Platform

Resolved

The unscheduled maintenance has been completed.
Posted Mar 04, 2025 - 14:37 UTC

Identified

We want to inform you that our scheduled maintenance has been extended due to unforeseen circumstances. We are working diligently to complete the process as soon as possible and will provide updates as needed.
Posted Mar 04, 2025 - 08:10 UTC
This incident affected: PPRO Infrastructure (Transaction Processing Platform).