After validating the impact of the maintenance, PPRO want to inform you that the maintenance has successfully completed and all affected services are operational.
Posted Mar 23, 2025 - 07:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 22, 2025 - 23:30 UTC
Update
The scheduled maintenance window has been changed for: BLIK. The service might be degraded between: 2025-03-22 23:30:00 & 2025-03-23 06:00:00 UTC. For details about the possible performance impacts for this service, please refer to our official Service Announcements emails.
Posted Mar 22, 2025 - 02:06 UTC
Update
The scheduled maintenance window has been changed for: BLIK - Mobile transfers. The service might be degraded between: 2025-03-22 23:30:00 & 2025-03-23 03:30:00 UTC. For details about the possible performance impacts for this service, please refer to our official Service Announcements emails.
Posted Mar 18, 2025 - 09:39 UTC
Scheduled
A scheduled maintenance window has been announced for BLIK. The service might be degraded between: 2025-03-22 23:30:00 & 2025-03-23 03:30:00 UTC. For details about the possible performance impacts for this service, please refer to our official Service Announcements emails.
Posted Feb 22, 2025 - 06:10 UTC
This scheduled maintenance affected: Payment Methods (BLIK).