Settlement Services: Resolved Service Disruption - EUR Settlements

Incident Report for PPRO Acquiring Platform

Resolved

The external service disruption of Settlement Services - EUR Settlements has been resolved and the service is again operating inside the normal performance parameters. Please refer to our official Service Announcement emails for further details.
Posted Feb 28, 2025 - 01:43 UTC

Identified

The ongoing TARGET Services incident is impacting settlements, causing delays in payment processing. The ECB is actively working on resolving the issue, with recovery measures in progress. Clients may experience delays in EURO settlement finalization until normal operations resume. We are closely monitoring the situation and will provide further updates as they become available.

Root Cause: External to PPRO

For more details on this degradation, please refer to the official ECB webpage:: https://www.ecb.europa.eu/paym/target/html/target2_history.en.html
Posted Feb 27, 2025 - 17:06 UTC
This incident affected: PPRO Infrastructure (Settlement Services).