Bancontact: Unscheduled Maintenance - Bancontact Switch

Incident Report for PPRO Acquiring Platform

Resolved

The unscheduled maintenance has been completed.
Posted Jun 05, 2025 - 00:29 UTC

Identified

The disruption turned out to be an unscheduled maintenance by the provider.
Posted Jun 04, 2025 - 14:37 UTC
This incident affected: Payment Methods (Bancontact).