Trustly: Resolved Service Disruption - Luminor, LHV Pank
Incident Report for PPRO Acquiring Platform
Resolved
The external service disruption of Trustly - Luminor, LHV Pank has been resolved and the service is again operating inside the normal performance parameters. Please refer to our official Service Announcement emails for further details.
Posted Feb 08, 2024 - 13:20 UTC
Update
The identified external issue is still ongoing and technical teams of Trustly are continuing to work towards resolving the situation.
Posted Feb 08, 2024 - 11:42 UTC
Identified
The root cause has been identified as external to PPRO. Our support teams are in close collaboration with the external provider and are awaiting their finding and resolution steps.
Posted Feb 08, 2024 - 10:24 UTC
This incident affected: Payment Methods (Trustly).