The service degradation affecting Swish has been fully resolved by the PPRO engineering team. Operations have returned to normal performance parameters. Please consult our official service announcement emails for further information.
Posted Apr 19, 2026 - 16:06 UTC
Monitoring
The service degradation affecting Swish has reportedly been resolved. We are currently monitoring the recovery of Swish extensively to ensure that performance remains stable before we formally conclude this incident.
Posted Apr 19, 2026 - 15:51 UTC
Identified
This degradation has been attributed to an internal system change and is currently being analysed. Our technical teams are actively working toward a resolution. A further update will be issued once the necessary remediation steps have been scheduled..
Posted Apr 19, 2026 - 15:50 UTC
Investigating
The PPRO monitoring system has identified a Severe Service Degradation affecting Swish. Our internal engineering team is currently investigating the root cause to ensure a swift resolution. Please refer to our official service announcement emails for further details.