paysafecard: Resolved Service Disruption
Incident Report for PPRO Acquiring Platform
Resolved
The external service disruption of paysafecard has been resolved and the service is again operating inside the normal performance parameters. Please refer to our official Service Announcement emails for further details.
Posted Aug 16, 2022 - 09:58 UTC
Investigating
We are currently investigating this issue.
Posted Aug 16, 2022 - 08:38 UTC
This incident affected: Payment Methods (paysafecard).