MB Way: Resolved Service Disruption - Refund
Incident Report for PPRO Acquiring Platform
Resolved
The external service disruption of MB Way - Refund has been resolved and the service is again operating inside the normal performance parameters. Please refer to our official Service Announcement emails for further details.
Posted Jul 16, 2024 - 03:24 UTC
Investigating
The PPRO monitoring system has detected a Partial Service Disruption of MB Way - Refund which we are currently investigating. Please refer to our official Email Service Announcements for further details.
Posted Jul 16, 2024 - 03:17 UTC
This incident affected: Payment Methods (MB Way).