Twint: Full Service Disruption
Incident Report for PPRO Acquiring Platform
Resolved
This incident has been resolved.
Posted Jan 26, 2025 - 11:40 UTC
Investigating
The PPRO monitoring system has detected a Full Service Disruption of Twint which we are currently investigating. Please refer to our official Email Service Announcements for further details.
Posted Jan 26, 2025 - 10:07 UTC
This incident affected: Payment Methods (Twint).