We have determined based on the conversion rate that the affected bank(s) have returned to normal operations.
Posted Sep 17, 2026 - 21:00 UTC
Monitoring
We have received notification that the payment scheme has returned to normal operations. We are also confirming that the performance of this payment scheme has recovered to the expected service levels. We will continue to monitor the payment scheme's performance before closing the open incident with the payment scheme.
Posted Sep 17, 2026 - 19:04 UTC
Identified
We have detected a partial service disruption at this payment method but we have noticed that the disruption it’s external.
Posted Sep 17, 2026 - 17:52 UTC
Investigating
The PPRO monitoring system has identified a Severe Service Degradation affecting Transaction Processing Platform. Our internal engineering team is currently investigating the root cause to ensure a swift resolution. Please refer to our official service announcement emails for further details.
Posted Sep 17, 2026 - 17:16 UTC
This incident affected: Payment Methods (Credit Card - France).