[External] iDeal | ABN Amro | Resolved Partial Service Degradation

Incident Report for PPRO Acquiring Platform

Resolved

The external service provider/partner has confirmed a full resolution regarding the recent service degradation. Operations have returned to normal performance parameters. Please consult our official service announcement emails for further information.
Posted Apr 11, 2026 - 23:37 UTC

Investigating

The PPRO monitoring system has identified a Partial Service Degradation affecting iDeal. Our internal engineering team is currently investigating the root cause to ensure a swift resolution. Please refer to our official service announcement emails for further details.
Posted Apr 11, 2026 - 23:18 UTC