After validating the impact of the maintenance, PPRO want to inform you that the maintenance has successfully completed and all affected services are operational.
Posted Jan 28, 2025 - 11:09 UTC
Completed
After validating the impact of the maintenance, PPRO want to inform you that the maintenance has successfully completed and all affected services are operational.
Posted Jan 28, 2025 - 08:04 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 28, 2025 - 07:00 UTC
Scheduled
A scheduled maintenance window has been announced for paysafecard - Rapid Transfer. The service might be degraded between: 2025-01-28 07:00:00 & 2025-01-28 08:00:00 UTC. For details about the possible performance impacts for this service, please refer to our official Service Announcements emails.
Posted Jan 24, 2025 - 07:45 UTC
This scheduled maintenance affected: Payment Methods (paysafecard).