The external service provider/partner has confirmed a full resolution regarding the recent service degradation. Operations have returned to normal performance parameters. Please consult our official service announcement emails for further information.
Posted Apr 14, 2026 - 09:34 UTC
Update
This issue has been confirmed as a service degradation at the provider/partner level. We remain in close contact with their technical support team and are currently awaiting their schedule for resolution.
Posted Apr 14, 2026 - 08:50 UTC
Identified
This degradation has been attributed to an internal system change and is currently being analysed. Our technical teams are actively working toward a resolution. A further update will be issued once the necessary remediation steps have been scheduled.
Posted Apr 14, 2026 - 08:38 UTC
Investigating
The PPRO monitoring system has identified a Partial Service Degradation affecting BLIK. Our internal engineering team is currently investigating the root cause to ensure a swift resolution. Please refer to our official service announcement emails for further details.