Trustly: Resolved Service Disruption
Incident Report for PPRO Acquiring Platform
Resolved
We
Posted Feb 05, 2024 - 22:13 UTC
Investigating
The PPRO monitoring system has detected a Full Service Disruption of Trustly which we are currently investigating. Please refer to our official Email Service Announcements for further details.
Posted Feb 05, 2024 - 21:59 UTC
This incident affected: Payment Methods (Trustly).