BLIK: Unscheduled Maintenance

Incident Report for PPRO Acquiring Platform

Resolved

The unscheduled maintenance has been completed.
Posted Mar 02, 2025 - 05:11 UTC

Identified

The disruption turned out to be an unscheduled maintenance by the provider.
Posted Mar 02, 2025 - 03:35 UTC
This incident affected: Payment Methods (BLIK).