Credit Card - Mexico: Resolved Service Disruption - BBVA - Openpay

Incident Report for PPRO Acquiring Platform

Resolved

The internal service disruption of Credit Card - Mexico - BBVA - Openpay has been resolved and the service is again operating inside the normal performance parameters. Please refer to our official Service Announcement emails for further details.
Posted Apr 24, 2025 - 15:48 UTC

Identified

An internal issue has been identified and our technical teams are working towards resolving the situation.
Posted Apr 24, 2025 - 15:24 UTC
This incident affected: Payment Methods (Credit Card - Mexico).