BLIK: Scheduled Maintenance

Scheduled for Apr 5, 21:00 UTC  -  Apr 6, 09:30 UTC

Update

The scheduled maintenance window has been changed for: BLIK. The service might be degraded between: 2025-04-05 21:00:00 & 2025-04-06 09:30:00 UTC. For details about the possible performance impacts for this service, please refer to our official Service Announcements emails.
Posted Apr 04, 2025 - 01:12 UTC

Scheduled

A scheduled maintenance window has been announced for BLIK. The service might be degraded between: 2025-04-06 00:30:00 & 2025-04-06 09:30:00 UTC. For details about the possible performance impacts for this service, please refer to our official Service Announcements emails.
Posted Apr 03, 2025 - 03:26 UTC
This scheduled maintenance affects: Payment Methods (BLIK).