MB Way: Unscheduled Maintenance
Incident Report for PPRO Acquiring Platform
Resolved
The unscheduled maintenance has been completed.
Posted Oct 21, 2024 - 03:11 UTC
Identified
The disruption turned out to be an unscheduled maintenance by the provider.
Posted Oct 21, 2024 - 02:08 UTC
This incident affected: Payment Methods (MB Way).