[External] MB multibanco | | Resolved Partial Service Degradation

Incident Report for PPRO Acquiring Platform

Resolved

The external service provider/partner has confirmed a full resolution regarding the recent service degradation. Operations have returned to normal performance parameters. Please consult our official service announcement emails for further information.
Posted Apr 20, 2026 - 02:27 UTC

Identified

This issue has been confirmed as a service degradation at the provider/partner level. We remain in close contact with their technical support team and are currently awaiting their schedule for resolution.
Posted Apr 20, 2026 - 02:25 UTC
This incident affected: Payment Methods (MB multibanco).