Przelewy24: Resolved Service Disruption - Refunds
Incident Report for PPRO Acquiring Platform
Resolved
The internal service disruption of Przelewy24 - Refunds has been resolved and the service is again operating inside the normal performance parameters. Please refer to our official Service Announcement emails for further details.
Posted Nov 13, 2024 - 01:02 UTC
Identified
An internal issue has been identified and our technical teams are working towards resolving the situation.
Posted Nov 12, 2024 - 23:32 UTC
This incident affected: Payment Methods (Przelewy24).