[External] Przelewy24 | Bank Millennium | Resolved Partial Service Degradation

Incident Report for PPRO Acquiring Platform

Resolved

The external service provider/partner has confirmed a full resolution regarding the recent service degradation. Operations have returned to normal performance parameters. Please consult our official service announcement emails for further information.
Posted Apr 15, 2026 - 22:17 UTC

Identified

This degradation has been attributed to an internal system change and is currently being analysed. Our technical teams are actively working toward a resolution. A further update will be issued once the necessary remediation steps have been scheduled.
Posted Apr 15, 2026 - 21:03 UTC
This incident affected: Payment Methods (Przelewy24).