After validating the impact of the maintenance, PPRO want to inform you that the maintenance has successfully completed and all affected services are operational.
Posted Mar 16, 2025 - 05:43 UTC
Completed
After validating the impact of the maintenance, PPRO want to inform you that the maintenance has successfully completed and all affected services are operational.
Posted Mar 16, 2025 - 05:42 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 16, 2025 - 01:00 UTC
Scheduled
A scheduled maintenance window has been announced for Swish - Nordea. The service might be degraded between: 2025-03-16 01:00:00 & 2025-03-16 05:00:00 UTC. For details about the possible performance impacts for this service, please refer to our official Service Announcements emails.
Posted Mar 11, 2025 - 07:29 UTC
This scheduled maintenance affected: Payment Methods (Swish).