Przelewy24: Resolved Service Disruption - Refunds

Incident Report for PPRO Acquiring Platform

Resolved

The external service disruption of Przelewy24 - Refunds has been resolved and the service is again operating inside the normal performance parameters. Please refer to our official Service Announcement emails for further details.
Posted Apr 28, 2025 - 08:17 UTC

Investigating

The PPRO monitoring system has detected a Partial Service Disruption of Przelewy24 - Refunds which we are currently investigating. Please refer to our official Email Service Announcements for further details.
Posted Apr 28, 2025 - 07:00 UTC
This incident affected: Payment Methods (Przelewy24).