RS2 Acquiring: Resolved Service Disruption - Novatti

Incident Report for PPRO Acquiring Platform

Resolved

The external service disruption of RS2 Acquiring - Novatti has been resolved and the service is again operating inside the normal performance parameters. Please refer to our official Service Announcement emails for further details.
Posted May 06, 2025 - 11:14 UTC

Investigating

The PPRO monitoring system has detected a Partial Service Disruption of RS2 Acquiring - Novatti which we are currently investigating. Please refer to our official Email Service Announcements for further details.
Posted May 06, 2025 - 11:12 UTC
This incident affected: Orchestration Connections (RS2 Acquiring).